阿里云虛擬主機中php網(wǎng)站運行提示PHP Fatal error處理辦法
使用阿里云Linux 系統(tǒng)虛擬主機,訪問 PHP 程序網(wǎng)站或者打開某個頁面出現(xiàn)報錯信息提示 “PHP Fatal error: Maximun execution time of 30 seconds exceeded in….", 如下圖:

![1579599628103068.png 18082101[1].png](/data/upload/image/20200121/1579599628103068.png)
問題原因
目前 Linux 系統(tǒng)虛擬主機服務(wù)器端 php.ini 配置文件中針對 max_execution_time 的設(shè)置統(tǒng)一是 30s,這個設(shè)定目前不支持修改,如果網(wǎng)站程序某個腳本運行時間超過 30s 就出現(xiàn)這個報錯,該參數(shù)不能設(shè)置過大的原因是因為考慮服務(wù)器的穩(wěn)定性原因,如果該參數(shù)過大,在虛擬主機中很容易導(dǎo)致程序缺陷產(chǎn)生對服務(wù)器嚴重的耗資源影響。
解決方法
建議聯(lián)系網(wǎng)站的程序開發(fā)人員調(diào)整優(yōu)化一下程序代碼,一般的程序網(wǎng)頁腳本超過30秒的運行時間還未結(jié)束程序代碼需要進行分析優(yōu)化。該錯誤場景也常見與程序批量生成靜態(tài)化頁面的后臺處理中,如果大批量生成靜態(tài)頁面需要腳本運行較長時間,這在虛擬主機中會導(dǎo)致觸發(fā)超時參數(shù)設(shè)置,建議一次生成少量的靜態(tài)頁面來避免該問題;
建議使用阿里云服務(wù)器 ECS,該類型主機擁有管理員權(quán)限,可以登陸服務(wù)器修改 php.ini 配置文件,調(diào)整此設(shè)置的時間大小,但該產(chǎn)品需要具備一定的服務(wù)器維護能力。
標簽
熱門文章更多>
- 南昌阿里云代理商:阿里云服務(wù)器網(wǎng)站訪問速度慢怎么排查?
- 貴陽阿里云代理商:阿里云服務(wù)器遷移需要注意哪些問題?
- 昆明阿里云代理商:阿里云服務(wù)器海外地域怎么選擇?
- 云服務(wù)器SSL配置完成后為什么還提示不安全?常見原因排查
- 阿里云SSL證書怎么部署?開啟HTTPS后還需要做哪些安全設(shè)置
- 企業(yè)VPN網(wǎng)關(guān)怎么搭建?本地機房連接云服務(wù)器內(nèi)網(wǎng)完整思路
- 濟南阿里云代理商:阿里云服務(wù)器公網(wǎng)IP有什么作用?
- 青島阿里云代理商:阿里云ECS快照和備份有什么區(qū)別?
- 鄭州阿里云代理商:阿里云服務(wù)器4核16G適合哪些業(yè)務(wù)?
- 北京阿里云代理商:阿里云ECS服務(wù)器如何選擇實例規(guī)格?
- 廣州阿里云代理商:阿里云服務(wù)器5M帶寬夠不夠用?
- 上海阿里云代理商:阿里云服務(wù)器企業(yè)采購要注意哪些問題?
- 阿里云代理商:阿里云服務(wù)器快照有什么作用?
- 阿里云代理商:阿里云CDN和OSS怎么搭配使用?
- 阿里云代理商:阿里云負載均衡SLB是什么?
- 深圳阿里云代理商:ECS部署SSL證書與到期提醒配置全攻略
- 上海阿里云代理商:阿里云服務(wù)器SSL證書備份方案
- 北京阿里云代理商:RDS讀寫分離配置指南
- 重慶阿里云代理商:用好 OSS 生命周期 降低長期存儲花費
- 上海阿里云代理商:DMS 多庫同步搭建 異構(gòu)數(shù)據(jù)庫集成實操

